Kube Installation Instructions

Installation of Kube currently requires the use of flatpak on Linux, and is available for Linux and Mac desktop operating systems only.

Flatpak installation

Use the Flatpak Ref file to install Kube directly, or run the following commands in the console:

$ flatpak -y --user install --from https://files.kube-project.com/kolabnowflatpak/com.kolabnow.kube.flatpakref
$ flatpak run com.kolabnow.kube

The first dialog you’ll see asks for your name and email address. The screen thereafter will ask for your account password.

Mac OS installation

Download and run the Mac OS Image.

Posted in Documentation and tagged , .

10 Comments

  1. Doesn’t work on my KDE Neon. Error:
    fosborne@fosborne-linux-desktop:~$ flatpak run com.kolabnow.kube
    libGL error: No matching fbConfigs or visuals found
    libGL error: failed to load driver: swrast
    Unrecognized OpenGL version
    Unrecognized OpenGL version

    First cmd finally completed w/o error after 3 attempts. Would like to try Kube but it will not install and run.

  2. installation works fine and it runs all fine.
    But i cant uninstall it.
    “flatpak remotes” shows “kolabruntime” as a remote.
    “flatpak remote-delete kolabruntime” and typing in the password ends in this error.
    GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code1: Remote “kolabruntime” not found

    Full output with -v option is this:
    flatpak remote-delete -v kolabruntime
    XA: Opening system flatpak installation at path /var/lib/flatpak
    XA: Calling system helper: ConfigureRemote
    Fehler: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code1: Remote “kolabruntime” not found

    dont know how to fix this.

    Same with the application itself:
    flatpak list shows
    com.kolabnow.kube/x86_64/master user,current
    org.kolab.Platform/x86_64/0.1 user,runtime

    as installed.
    but typing “flatpak uninstall com.kolabnow.kube” and hitting enter results in “Fehler: com.kolabnow.kube master ist nicht installiert

    even though “flatpak run com.kolabnow.kube” starts the application.

    Do you know how to fix this?

  3. Hi

    This is not working for me on Mint 18.3 KDE. I’m getting this in the terminal:

    error: No such ref ‘app/com.kolabnow.kube/i386/master’ in remote com.kolabnow.kube-3-origin

    I’m wondering if the package is only for x86_64, and not for us dinosaurs with only 32 bits.

    If my assumption is correct, are there plans for supporting 32 bit Linux?

    Many thanks.

  4. Is it possible to use Kube without a Kolab Now account? The initial wizard doesn’t seem to allow use of the application with any other provider.

Leave a Reply

Your email address will not be published. Required fields are marked *